Project

General

Profile

Feature #86299

ENI SEIS South Website -events listed on the home page

Added by Stefania Tomasina 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
ENI-SEIS
Start date:
2017-06-23
Due date:
% Done:

100%


Description

I would like to know if the events listed in the home page, update by themselves or not and if yes, where do they get the input form?
I think that the latest inserted event should always feature on the top of the list especially in the home page, without having to insert it twice in two different place.
Right now, I don't see the latest inserted event on the home page.
Thanks for your kind assistance.
Best
Stefania

Associated revisions

Revision 6e4ed96a (diff)
Added by Ghiță Bizău 4 months ago

[refs #86299] Homepage - use upcoming events from get_upcoming_events view.

Revision e556fce5 (diff)
Added by Ghiță Bizău 4 months ago

[refs #86299] get_upcoming_events view.

Revision d45720ca (diff)
Added by Ghiță Bizău 4 months ago

[refs #86299] Homepage - show next 4 upcoming events.

Revision 36352665 (diff)
Added by Ghiță Bizău 4 months ago

[refs #86299] Homepage - show next 4 upcoming events.

Revision c87a3d9d (diff)
Added by Ghiță Bizău 4 months ago

[refs #86299] Use tag 3.1.

History

#1 Updated by Miruna Badescu 4 months ago

  • Status changed from New to Accepted in Queue
  • Assignee changed from Miruna Badescu to Ghita Bizau

#2 Updated by Ghita Bizau 4 months ago

  • Status changed from Accepted in Queue to In Progress

#3 Updated by Ghita Bizau 4 months ago

  • Status changed from In Progress to Acceptance/Demo
  • % Done changed from 0 to 100

#4 Updated by Ghita Bizau 4 months ago

  • Status changed from Acceptance/Demo to To be deployed
  • Assignee changed from Ghita Bizau to Anton Cupcea

Implemented: upcoming events in homepage meaning the next 4 Event or eea.meeting items from now (ordered by start date of event). This is similar with Upcoming Events list of Copernicus Land - we want the next events instead of latest modified or added.

@Anton
Please update the demo and production websites.

#5 Updated by Anton Cupcea 4 months ago

  • Status changed from To be deployed to Acceptance/Demo
  • Assignee changed from Anton Cupcea to Ghita Bizau

#6 Updated by Ghita Bizau 4 months ago

  • Status changed from Acceptance/Demo to Closed
  • Assignee changed from Ghita Bizau to Stefania Tomasina

The problem is fixed now.
http://eni-seis.eionet.europa.eu/south
The next 4 upcoming events (Event and eea.meeting items) are displayed automatically (no need to edit manually this section).

The start date of event is considered when ordering the items. So, today (28.06.2017) the upcoming events are: 4-6.07.2017, 16-21.07.2017, 18-19.09.2017, 03.10-04.11.2017.

Adding an event for 03.2018 will not change this list now, but the event will appear in list when it will be in the top 4 closest future events (maybe in 01.2018 or 02.2018).

Also available in: Atom PDF