Project

General

Profile

Bug #69697

Chrome does not display BISE pages correctly

Added by Mette Palitzsch Lund over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
BISE - maintenance
Target version:
Start date:
2016-02-25
Due date:
% Done:

100%

Keywords:
Complexity:

Description

Several pages are not well aligned when using Chrome for browsing BISE. It looks fine in IE Explorer.
e.g. http://biodiversity.europa.eu/info

I'm using Google Chrome Version 48.0.2564.116 m

visualisation errors.JPG View (81.3 KB) Mette Palitzsch Lund, 2016-02-25 11:42

21169

Related issues

related to BISE - Bug #68176: Cannot publish document Closed 2016-01-21
related to BISE - Feature #67937: EPIC (analysis and splitting task): User interface across the six entry points of BISE and home page Closed 2016-01-14
duplicated by BISE - Bug #23765: interactive elements not working properly Invalid/Expired 2015-03-09

Associated revisions

Revision ce950f62 (diff)
Added by Tiberiu Ichim over 1 year ago

Refs #69697 Bise; fix a problem with Chrome rendering of layout

History

#1 Updated by Mette Palitzsch Lund over 1 year ago

  • related to Bug #68176: Cannot publish document added

#2 Updated by Mette Palitzsch Lund over 1 year ago

  • Subject changed from Chrome dpes not display BISE pages correctly to Chrome does not display BISE pages correctly

#3 Updated by Ilkka Melleri over 1 year ago

  • Tracker changed from Task to Bug
  • Assignee changed from Ilkka Melleri to EDW BISE Developers
  • Target version set to BISE - Queue - DEPRECATED by agile board

#4 Updated by Ilkka Melleri over 1 year ago

  • duplicated by Bug #23765: interactive elements not working properly added

#5 Updated by Miruna Badescu over 1 year ago

  • Status changed from New to In Progress
  • Assignee changed from EDW BISE Developers to Ichim Tiberiu
  • Target version changed from BISE - Queue - DEPRECATED by agile board to BISE - Work In Progress - DEPRECATED by agile board

#6 Updated by Ichim Tiberiu over 1 year ago

  • % Done changed from 0 to 10

I thought that maybe one of the zope instances is unsynchronized, but it seems that there is a bug with Chrome.

The problems seems to be related to the box-shadow applied to the #portal-columns

Specifically, in this rule:


#portal-columns {
    border-top: 1px solid #D4D9CC;
    border-left: 1px solid #D4D9CC;
    border-right: 1px solid #D4D9CC;
    -moz-box-shadow: 0 0 6px 7px #DFE5D7;
    -webkit-box-shadow: 0 6px 7px #DFE5D7;
    box-shadow: 0 0 6px 7px #DFE5D7;
    background-color: white;
    margin-left: 9px;
    width: 943px;
}

If I disable any of the drop shadows from the Chrome Inspector (the -webkit line, or the box-shadow line), the background is corrected.

#7 Updated by Ichim Tiberiu over 1 year ago

  • % Done changed from 10 to 90

With the help of Valentin Popescu, we've identified the cause of bug as being that of "heavy/complicated rendering".

I've fixed the problem in custom skin, a code based solution will be available at the next deployment.

#8 Updated by Ichim Tiberiu over 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

#9 Updated by Ichim Tiberiu over 1 year ago

  • Target version changed from BISE - Work In Progress - DEPRECATED by agile board to BISE - Done 2016 Q1

#10 Updated by Miruna Badescu about 1 year ago

  • related to Feature #67937: EPIC (analysis and splitting task): User interface across the six entry points of BISE and home page added

#11 Updated by Antonio De Marinis about 1 year ago

  • Parent task set to #77012

Also available in: Atom PDF