Project

General

Profile

Task #69412

Feature #69192: Project deliverables

Task #69408: 1. CDDA Designated Areas

1.3 CDDA: Data transformation

Added by Darja Lihteneger almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Urgent
Category:
Project deliverable
Start date:
2016-02-17
Due date:
% Done:

100%

Estimated time:

Description

This package of the deliverables include:
- Matching table with included mapping rules describing what and how to perform the data transformation (MS Excel)
- Source data: input data samples
- Transformed data in GML
- HALE alignment project (embedded mapping and data transformation functionality)

The sample source data used in data transformation include:
- reported data delivery from Croatia
- reported data deliverv from Netherlands
- selection from the European data set of CDDA, 10 entries per each country, data allowed for public dissemination
- selection from the European data set of CDDA of the French oversea territories.

The sample source data are transformed into GML files according to the same CDDA GML schema and the mapping rules.

Exception for Turkey: the source data and the transformed data are available in the EEA only.

CddaReporting_HRV_V3.0.align (110 KB) CddaReporting_HRV_V3.0.align HRV: HALE alignment María Cabello, 2016-02-24 19:08
CddaReporting_HRV_Source data.7z (1.34 MB) CddaReporting_HRV_Source data.7z HRV: Source data: input data samples María Cabello, 2016-02-24 19:08
CddaReporting_HRV_V3.0.gml (6.81 MB) CddaReporting_HRV_V3.0.gml HRV: Transformed data in GML María Cabello, 2016-02-24 19:08
CddaReporting_NLD_V3.0.align (105 KB) CddaReporting_NLD_V3.0.align NLD: HALE alignment María Cabello, 2016-02-24 19:15
CddaReporting_NLD_V3.0.gml.7z (27.7 MB) CddaReporting_NLD_V3.0.gml.7z NLD: Transformed data in GML María Cabello, 2016-02-24 19:16
CddaReporting_NLD_Source data.7z (21.7 MB) CddaReporting_NLD_Source data.7z NLD: Source data: input data samples María Cabello, 2016-02-24 19:16
CddaReporting_10R_V3.0.align (60.7 KB) CddaReporting_10R_V3.0.align Sample 10R Countries: HALE alignment María Cabello, 2016-02-24 19:18
CddaReporting_10R_V3.0.gml (14.6 MB) CddaReporting_10R_V3.0.gml Sample 10R Countries: Transformed data in GML María Cabello, 2016-02-24 19:18
CddaReporting_AL_GUF_V3.0.align (55.1 KB) CddaReporting_AL_GUF_V3.0.align Overseas: HALE alignment María Cabello, 2016-02-24 19:37
CddaReporting_GUF_V3.0.gml (2.69 MB) CddaReporting_GUF_V3.0.gml Overseas: Transformed data in GML María Cabello, 2016-02-25 11:27
CddaReporting_HRV_V3.0point.gml (455 KB) CddaReporting_HRV_V3.0point.gml HRV: Transformed points in GML María Cabello, 2016-02-25 11:27
CddaReporting_HRV_V3.0poly.gml (6.36 MB) CddaReporting_HRV_V3.0poly.gml HRV: Transformed polygons in GML María Cabello, 2016-02-25 11:27
CddaReporting_NLD_V3.0_Sites.gml (6.77 MB) CddaReporting_NLD_V3.0_Sites.gml NLD: Transformed sites in GML María Cabello, 2016-02-25 11:28
CddaReporting_NLD_V3.0_DB.gml (78.6 MB) CddaReporting_NLD_V3.0_DB.gml NLD: Transformed designation boundaries in GML María Cabello, 2016-02-25 11:28
CddaReporting_MT_V3.0.xlsx (190 KB) CddaReporting_MT_V3.0.xlsx Matching table with included mapping rules describing what and how to perform the data transformation (MS Excel) María Cabello, 2016-02-25 12:58

History

#1 Updated by Darja Lihteneger almost 2 years ago

  • Subject changed from 3 Data transformation to CDDA 3 Data transformation

#2 Updated by Darja Lihteneger almost 2 years ago

  • Subject changed from CDDA 3 Data transformation to CDDA: 3 Data transformation

#3 Updated by Darja Lihteneger almost 2 years ago

  • Subject changed from CDDA: 3 Data transformation to 1.3 CDDA: Data transformation

#7 Updated by María Cabello over 1 year ago

#8 Updated by María Cabello over 1 year ago

  • File deleted (CddaReporting_GUF_V3.0.gml)

#11 Updated by María Cabello over 1 year ago

  • File deleted (CddaReporting_MT_V3.0.xlsx)

#13 Updated by Mette Palitzsch Lund over 1 year ago

Please add information about which version of the Hale software was used.

#14 Updated by Darja Lihteneger over 1 year ago

Dear Maria,

Could you add information what kind of source data formats (Shapefil, Spatialite) were used for data transformation in each transformation case.
Kind regards,

Darja

#15 Updated by María Cabello over 1 year ago

  • Assignee changed from María Cabello to Darja Lihteneger

#16 Updated by Darja Lihteneger over 1 year ago

  • Assignee changed from Darja Lihteneger to Leire Leoz
  • Priority changed from Normal to Urgent

Dear Leire,

For clarification:
what is now the correct name of the GML schema and the schema location that you use in data transformation:
CddaReporting_V3.0.xsd or
CddaReporting.xsd (you haven't uploaded this schema)

We need to update the file in data dictionary accordingly.

In the GML file is:
http://dd.eionet.europa.eu/schemaset/cdda/CddaReporting.xsd

<wfs:FeatureCollection xmlns:gco="http://www.isotc211.org/2005/gco"
xmlns:cdda="http://dd.eionet.europa.eu/schemaset/cdda"
xmlns:gn="http://inspire.ec.europa.eu/schemas/gn/4.0"
xmlns:base="http://inspire.ec.europa.eu/schemas/base/3.3"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:ns1="http://www.w3.org/1999/xhtml"
xmlns:gml="http://www.opengis.net/gml/3.2"
xmlns:ps="http://inspire.ec.europa.eu/schemas/ps/4.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:wfs="http://www.opengis.net/wfs/2.0"
xsi:schemaLocation="http://dd.eionet.europa.eu/schemaset/cdda http://dd.eionet.europa.eu/schemaset/cdda/CddaReporting.xsd http://www.opengis.net/wfs/2.0 http://schemas.opengis.net/wfs/2.0/wfs.xsd" numberMatched="92" numberReturned="92" timeStamp="2016-02-25T10:42:50.368+01:00">
<wfs:member>

#17 Updated by Leire Leoz over 1 year ago

Dear Darja,

On the one hand, the naming of deliverables was established (including the version in the name of the schema file) and, on the other hand, the schema location was decided. As versioning is important for the project, we thought the objective was maintaining it in taskman but keeping the name without versioning in the final public xsd.
The GML schema is uploaded and the URL of the schema location works properly (both http://dd.eionet.europa.eu/schemaset/cdda/CddaReporting.xsd and http://dd.eionet.europa.eu/schemaset/cdda/CddaReporting_V3.0.xsd), it is just a naming issue. GML instances refer to the final public xsd without versioning.

Kind regards,
Leire

#18 Updated by Darja Lihteneger over 1 year ago

  • % Done changed from 0 to 90

Dear Leire,

Thank you for the reply.
The issue is that we still have the old schemas in the Data Dictionary. We need to point to the correct file names.
http://dd.eionet.europa.eu/schema/cdda/CddaReporting_V3.0.xsd
http://dd.eionet.europa.eu/schema/designation-type/DesignationType_V3.0.xsd

This will have to change.
Kind regards,

Darja

#19 Updated by Darja Lihteneger over 1 year ago

  • Assignee changed from Leire Leoz to Darja Lihteneger

This package of the deliverables include:
- Matching table with included mapping rules describing what and how to perform the data transformation (MS Excel)
- Source data: input data samples
- Transformed data in GML
- HALE alignment project (embedded mapping and data transformation functionality)

The sample source data used in data transformation include:
- reported data delivery from Croatia
- reported data deliverv from Netherlands
- selection from the European data set of CDDA, 10 entries per each country, data allowed for public dissemination
- selection from the European data set of CDDA of the French oversea territories.

The sample source data are transformed into GML files according to the same CDDA GML schema and the mapping rules.

Exception for Turkey: the source data and the transformed data are available in the EEA only.

#20 Updated by Darja Lihteneger over 1 year ago

  • Description updated (diff)
  • Status changed from New to Closed

#21 Updated by Darja Lihteneger over 1 year ago

  • % Done changed from 90 to 100

#22 Updated by Darja Lihteneger over 1 year ago

  • Category set to Project deliverable

#23 Updated by Mette Palitzsch Lund over 1 year ago

The software used for the transformation is HALE (version V2.9.4), http://www.esdi-community.eu/projects/hale.

Also available in: Atom PDF